The Airheads Beemer Club is a non-profit club reclaiming the 'Legendary Motorcycles of Germany'

Topic-icon Odd issue with X-arc Duos

  • Hoobie7
  • Hoobie7's Avatar Topic Author
  • Offline
  • R100 Level
  • R100 Level
More
3 months 1 week ago - 3 months 1 week ago #4807 by Hoobie7
Replied by Hoobie7 on topic Odd issue with X-arc Duos
Ya, I also did not like the mismatched plug wires. I replaced them with these NGK 1k Ohm wires.
The application table says they should be right but I will look into that as well. Thanks for the tip!
Last edit: 3 months 1 week ago by Hoobie7.

Please Log in to join the conversation.

More
3 months 1 week ago #4812 by Wobbly
Replied by Wobbly on topic Odd issue with X-arc Duos
Just a warning. If that's the "NGK Application Table" you are referring to, then it is riddled with errors on older vehicles.

Don't hide 'em, Ride 'em !!
#15150

Please Log in to join the conversation.

  • Hoobie7
  • Hoobie7's Avatar Topic Author
  • Offline
  • R100 Level
  • R100 Level
More
3 months 1 week ago #4815 by Hoobie7
Replied by Hoobie7 on topic Odd issue with X-arc Duos
I looked at the Application Table tab on that page. The similar 5k ohm wires did not list R75, only R65 and R100. However I have also not been able to find a corroborating source yet.

Please Log in to join the conversation.

More
3 months 1 week ago #4816 by Wobbly
Replied by Wobbly on topic Odd issue with X-arc Duos

Wobbly wrote: If that's the "NGK Application Table" you are referring to....


My bad. It is NOT the NGK table you are looking at, but rather the EuroMotoElectrics table. I didn't see the link in the first post.

Don't hide 'em, Ride 'em !!
#15150

Please Log in to join the conversation.

Moderators: Wobbly
Time to create page: 0.984 seconds